
How to create VBFP reports using the 
Progress Reports Generator

Logging In
1. Request a username and password for the Progress Reports Generator by sending an email 

to clgsupport@clgsite.com

2. Install CutePDF Writer on your computer. This will allow you to print the reports on your 
computer.

3. Using Internet Explorer, go to clgsite.com and click on Cambridge Connect.

4. Click the Progress Reports Generator link. The first time you click the link, you may have to do 
one or more of the following (depending on which version of IE you are using):

• If the VBScript:Remote Desktop Connection window appears Click OK.

• If a yellow bar appears right above the top of the page, click it and then click Run to 
allow the Terminal Services ActiveX Client to run. Skip to step 5.

• Earlier versions of Internet Explorer may require the following:

• Click Tools

• Click Manage Add-ons 

• Click Enable or Disable Ad-ons

• The manage Add-ons window appears

• Click Microsoft Terminal Services Client Control (redist)

• Under settings click Enable

• Click Ok

5. In the size drop down list, choose the size of window you want to run the Progress Reports 
Generator in.

6. Click the Connect button.

7. When the Remote Desktop Connection window Appears make sure Printers is checked and 
then click Connect.

8. Enter your user name and password.

9. Next to Log on to: select CLGSERVER2 and click Ok.

10.You should now be in the Progress Reports Generator.

Data Entry Overview
1. If you are not already on the Data Entry Form, click the Data_Entry tab at the bottom of the 

screen.

2. Fill in the blanks for each section then press the Submit button for that section. Work you way 
down the page. 

3. Be sure and save your work often using File → Save on the menu or click the Save icon. 
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The Submit Buttons do not save your work. They copy the data into the corresponding 
database. (See tabs at bottom of spreadsheet)

• Meeting Date is the date of the upcoming progress meeting. It is very important that you 
enter this date correctly and consistently. All the reports are generated from the meeting 
date. If the meeting dates are not correct, the reports will not be correct, and/or the 
charts may not appear.

• Cells with red triangles in the corner contain notes to help you. Move the mouse over 
the cell to see them.

• Green text are formulas and will change automatically.

New Client Section
This is where you enter basic information about each client into the database. This information should 
be entered only once. You will not need to enter it again for subsequent meetings. (See Client_DB tab 
to check or edit data.)

1. In the New Client Section enter a Client ID. You can make up a Client ID or use one that you 
already have. It needs to be unique for each client. I recommend you not use spaces and 
special characters such as dashes, commas, hyphens, etc. If you have clients in different 
states FL001 and TX001 are examples you can use.

2. Continue to enter data for the rest of this section. Display Name is what gets displayed on the 
report titles.

3. Click the Submit New Client Data button to submit the data you entered for this section. Click 
OK.

4. You only have to do this one time for each client. For future reports, go to the Client_DB tab to 
look up a client's ID.

New Account Section
This is where you enter basic information about each account into the database. This information 
should be entered only once. You will not need to enter it again for subsequent meetings. If the client 
obtains new accounts later on, then you will have to enter the new accounts here, but only once.

1. Select the Client_ID from the drop down list. (You can also see a list of client ID's on the 
Client_DB tab)

2. Enter the Account Number. If your client has not yet supplied it, make one up. FL001CHK is 
an example for a checking account.

3. Enter the Account Name. This name will be used in the reports.

4. Select who the account belongs to: Her/Him/Both. This data is used on the circle chart.

5. If this is a retirement account, select r from the drop down list. It its not a retirement account 
select nr (non retirement).

6. Click Submit New Account button

7. Repeat the above process for each section that follows: Cash, Growth, Debt.
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Get Account Numbers
1. Select the Client_ID from the drop down list.

2. Enter the Meeting Date (date of the upcoming meeting).

3. Click the Get Account Numbers button. 

• This fills the drop down list in each section of the Data Entry form with the account 
numbers for the client you are working on.

• All of the charts and reports use what is entered in the orange section to generate 
their reports.

• If you click the Get_Acct tab at the bottom of the screen you will see a list of the 
accounts for the client. It also shows a list of entered meeting dates for each database. 
This will help you see if you accidentally entered a wrong meeting date.

Cash Reserves
1. Make sure the Correct Client ID and Meeting Date are displayed in the orange section 

toward the top of the data entry page. If not, enter them.

2. Select the Account Number from the drop down list. If your Account Number is not listed it 
means you did not enter it in the New Account Section and you must go back and do so.

3. Enter the Amount.

4. Enter As of Date. This is the date of the source of your information. For example, WealthServ 
Statements, Clients verbal report.

5. Click the Submit Cash Reserves Data button.

6. Repeat the process for each Cash Reserves account.

Growth Accounts
1. Make sure the Correct Client ID and Meeting Date are displayed in this section. If not, enter 

them in the orange section toward the top of the Data Entry page.

2. Select the Account Number from the drop down list. If your Account Number is not listed it 
means you did not enter it in the New Account Section and you must go back and do so.

3. Enter the Amount.

4. Enter As of Date. This is the date of the source of your information. For example, WealthServ 
Statements, Clients verbal report.

5. Click the Submit Growth Data button.

6. Repeat the process for each Growth account.

Debt Accounts
1. Make sure the Correct Client ID and Meeting Date are displayed in this section. If not, enter 

them in the orange section toward the top of the Data Entry page.

2. Select the Account Number from the drop down list. If your Account Number is not listed it 
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means you did not enter it in the New Account Section and you must go back and do so.

2. Enter the Amount.

3. Enter As of Date. This is the date for the amount in step 2.

4. Enter As of Date. This is the date of the source of your information. For example, WealthServ 
Statements, Clients verbal report.

5. Fill in the rest of the data.

6. Click the Submit Debt Data button.

7. Repeat the process for each debt account.

Not Included In Totals
The data entered in this section is used on the the Circle Chart to show other assets a client has that 
are not being managed by the Financial Advisor and/or are not included in the assets being used to 
fund the client's goals.

1. Make sure the Correct Client ID and Meeting Date are displayed in this section. If not, enter 
them in the orange section toward the top of the Data Entry page.

2. Select the Account Number from the drop down list. If your Account Number is not listed it 
means you did not enter it in the New Account Section and you must go back and do so.

3. Enter the Amount.

4. Enter Type. You can enter anything here to help describe the account such as residence or 
vehicle.

5. Fill in the rest of the data.

6. Click the Submit Not Included Data button.

7. Repeat the process for each  Not Included account.

Deposit Withdrawal Section
1. Make sure the Correct Client ID and Meeting Date are displayed in this section. If not, enter 

them in the orange section toward the top of the Data Entry page.

2. Select the Account Number from the drop down list. If your Account Number is not listed it 
means you did not enter it in the New Account Section and you must go back and do so.

3. Enter the total deposits made into this account since the last meeting.

4. Enter the total withdrawals made from this account since the last meeting.

5. Click the Submit Deposit/Withdrawal Data button.

6. Repeat the process for each account that received deposits or withdrawals since the last 
meeting.
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New Goal Section
This is where you enter data about each goal into the database. The goals should be entered only 
once. You will not need to re-enter the goals for subsequent meetings. If the client obtains a new goal 
later on, then you will have to enter the new goal here, but only once.

There are two types of goals: 

• Income Stream Goal – This type of goal will pay out money over time. Example: retirement.

• Single Event Goal– This type of goal will be paid out all at once on a future date. Example: 
Lake House, boat, new car.

1. Goal Order: This determines how the goals are stacked on the bar chart.

• Entering 1 puts the goal at the bottom of the bar chart.

• 2 puts the goal above 1.

• Lowest number will be at the bottom, highest at the top.

2. Name of Goal: Give the goal a name. The goal name is displayed on the Goal Progress 
Report. It should be the name as it appears on your client's FRM, but shorter names fit better.

3. Goal Date: Enter the goal date. 

• For a Single Event Goal, this will be the date the money needs to be available.

• For an Income Stream Goal, this is the date the goal will start paying money out.

4. Inflation Rate:  Enter what you think the inflation rate will be.

5. Single Event Goal:

• For Single Event Goals: enter the goal amount, skip to step 13.

• For Income Stream Goals: enter a zero here.

6. Goal End Date: Enter or select from the list the date you want the goal to stop paying money.

7. Growth Rate: Enter what you think the average percentage growth rate of the assets funding 
the goal will be.

8. Management Fee: Enter the average management fee for the clients entire portfolio.

9. Capital Gains: Enter the capital gains tax. If its 15% enter 15

10.Other Tax: Enter any other taxes here as a percentage. This is optional. Often this is zero.

11. Goal Yearly Income Net: Enter the yearly income goal stated by your client.

12.  Goal End Amount: Enter the amount (if any) the client wants left over at the Goal End Date.

13.Click the Just Calculate FGA button. If you are satisfied with the results, press the Calculate 
& Submit Goal to Database button. This will enter the goal into the database.

14.Repeat steps 1 – 13 for each goal.
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Editing data that has been submitted
Each section on the Data Entry page has an edit button out to the right. Use these buttons to edit 
your data. You may also edit your data directly in each spreadsheet. However, its probably a little 
safer to use the buttons. Always use the Data Entry page to enter new data.

When you click a button it will take you to the spreadsheet for that section and a form will pop up. Use 
this form to make changes to your data. The Goal data does not use a form. See Editing Goal Data 
below.

Before editing your data, SAVE YOUR WORK using File → Save. That way if you really mess 
things up you can simply close the spreadsheet without saving it and re-open it to get back 
where you were before editing.

How to use the form:

• The vertical scroll bar allows you to scroll through your data.

• Scroll to the data that needs to be changed, make your changes and then press the Close 
button.

• If you need to edit more than one record, make your change, then click the scroll bar to go to 
the next record or press Enter on your keyboard. This will save your changes. Warning: 
clicking Find Prev or Find Next will not save your changes.

• If you have a lot of records and you don't want to scroll through them all to find your data, you 
can use the Criteria button. Click the Criteria button, enter in what you are looking for and then 
use the Find Prev and Find Next buttons to scroll through the data that matches your criteria.
Once you find your data, make any necessary changes and then click the scroll bar to go to 
the next record to save your changes. You can also save your changes by pressing Enter on 
your Keyboard.  Warning: If you click Find Prev or Find Next, your changes will not be saved. 

• The delete button will delete the record from the spreadsheet.

• To make your changes permanent, save your work using File → Save. If you don't want 
to make your changes permanent, close the spreadsheet without saving. You will loose 
all your changes since the last time you saved.

Editing Goal Data
Before editing your data, SAVE YOUR WORK using File → Save. That way if you really mess 
things up you can simply close the spreadsheet without saving it and re-open  it to get back to 
where you where before editing.

The Edit Goal DB button will take you to the goal spreadsheet. However it will not open a form. You 
must make your changes directly in the spreadsheet. 

To re-order the goals for a client: 

• Locate the rows in the spreadsheet that need to be changed.

• Re-order the goals by changing the number in the column labeled Order.

• Scroll to the right and Click the Sort Goal DB button.
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To delete a goal:

• Click the row number containing your goal. This should select the entire row.

• Click the Edit Menu and then click Delete.

To update a goal with new values:

• You can delete the goal (see above) and re-enter it on the Data Entry page or

• Find the goal that needs updating. On the row of your goal, update your values. Select a cell 
anywhere on the row you changed. Click the button labeled: Calculate Future Goal Amount 
on current row. This will run a macro that will update the goal amounts.

Reports Overview
Before you run any reports, SAVE YOUR WORK using File → Save. That way if you really mess 
things up you can simply close the spreadsheet without saving it and re-open  it to get back to 
where you where when you saved.

1. Go to the orange section toward the top of the Data Entry form and select the Client and 
enter the date of the upcoming meeting.

2. Click the tab near the bottom of the window for the report you want:

• Behind = Behind the Numbers Report

• Circle = Circles of Money Report

• Charts = Goal Progress Report, Growth Progress Since Inception, Growth Progress 
Since Last Meeting.

• FRM_1 = FRM Numbers History

• FRM_2 = FRM Numbers History Detail

4. Click the Update button on each page to run the report. (For the Charts report you must also 
enter the date of the last meeting).

5. Print the report to the CutePDF printer (the one with your computer name) and it will allow you 
to save the file to your hard drive. You can then print the saved pdf to any of your local printers.

Behind the Numbers (Behind tab)
This is a simple report that displays the amounts and totals for cash reserves, growth and debt 
accounts.

1. Go to the orange section toward the top of the Data Entry form and select the Client and 
enter the date of the upcoming meeting.

2. Click tab labeled Behind at the bottom of the spreadsheet.

3. Click the Generate Behind the Numbers Report button.

4. Using the Excel Menu, click File → Print. Choose the CutePDF printer that contains your 
computer name.

5. Click Ok and CutePDF should pop up a window on your computer allowing you to save a PDF 
to your computer. You can then print the PDF to your local printer.
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Circles of Money (Circle tab)
Before you run this report, SAVE YOUR WORK using File → Save.

1. Go to the orange section toward the top of the Data Entry form and select the Client and 
enter the date of the upcoming meeting.

2. Click the tab labeled Circle at the bottom of the spreadsheet.

3. Click the Build Circle Chart button. Some of the circles should appear with the account 
names inside. Circles populate on top of each other, so don't be alarmed. These circles are 
static and will not change if you update the data. If you update your data, you will need to 
remove all the circles and rectangles within columns A – N and click the Build Circle Chart 
button again.

4. Please note: The Total Liabilities Box & The Not Included Box will be left over from  the 
previous client's data if you didn't enter that data for the current client. If this happens, 
just delete the boxes.

5. Click the Copy Circle Chart to New Sheet button. Move each circle to your desired location. 
Make sure you move every circle. Sometimes smaller circles get hidden underneath bigger 
ones. When you are finished, save the new sheet under a new name. This saved report is 
static and will not change if you update the data. 

6. Using the Excel Menu, click File → Print. Choose the CutePDF printer that contains your 
computer name.

7. Click Ok and CutePDF should pop up a window on your computer allowing you to save a PDF 
to your computer. You can then print the PDF to your local printer.

8. Close the new spreadsheet you just saved to get back to the Progress Reports Generator, 
(database_3.xls)

9. Prepare for the next report by removing all the circles and rectangles within columns A – N. Do 
this by holding down the shift key and clicking each rectangle and circle. When they are all 
selected, click the delete key on your keyboard. If you do not clear all the circles and 
rectangles, the next time you run the report, it will put new circles on top of the old ones.

Goals Progress Report, Growth Progress Since Inception, Growth 
Progress Since Last Meeting (Charts tab)

Goal Progress Report: This chart shows the progress of the client’s assets benchmarked against 
their goals in future dollar values.

Growth Progress Since Inception: This chart shows the progress of the client’s assets 
benchmarked against the original amounts brought to their Trusted Advisor to be managed.

Growth Progress Since Last Meeting: This chart shows the progress of the client’s assets 
compared to the values at the last meeting the client had with their Trusted Advisor.

1. Go to the orange section toward the top of the Data Entry form and select the Client and 
enter the date of the upcoming meeting.

2. Click tab labeled Charts at the bottom of the spreadsheet.

3. Enter the date of the last meeting, not the upcoming meeting.

4. Click the Update Goal Progress Report button.
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5. If necessary move the total label on the Goal Amount column to the correct location.

6. Make sure no charts are selected by clicking on an empty cell. To be sure, click on a cell 
outside the chart area.

7. Using the Excel Menu, click File → Print. Choose the CutePDF printer that contains your 
computer name.

8. Click Ok and CutePDF should pop up a window on your computer allowing you to save a PDF 
to your computer. You can then print the PDF to your local printer. All three charts should be 
contained within the pdf.

Annual Income from Current Assets, Total Progress (Alt_Charts tab)
These are alternate charts that are not normally given to the client.

Annual Income from Current Assets: This chart shows, in a historical manner, how much the client 
could anticipate as an annual income from their assets on the dates that they met with their Trusted 
Advisor.

Total Progress: This chart shows the historical values of the growth assets and debts at each 
meeting the client has had with their Trusted Advisor.

1. Go to the orange section toward the top of the Data Entry form and select the Client and 
enter the date of the upcoming meeting.

2. Click tab labeled Alt_Charts at the bottom of the spreadsheet.

3. Click the Update Charts button.

4. Make sure no charts are selected by clicking on an empty cell outside the chart area.

5. Using the Excel Menu, click File → Print. Choose the CutePDF printer that contains your 
computer name.

6. Click Ok and CutePDF should pop up a window on your computer allowing you to save a PDF 
to your computer. You can then print the PDF to your local printer. Both charts should be 
contained within the pdf.

FRM Numbers History (FRM_1 tab)
This chart reports the financial values of the FRM for every Progress Meeting along with deposits and 
withdrawals made by the client and the markets. 

1. Go to the orange section toward the top of the Data Entry form and select the Client and 
enter the date of the upcoming meeting.

2. Click tab labeled FRM_1 at the bottom of the spreadsheet.

3. Click the Update Report button.

4. Using the Excel Menu, click File → Print. Choose the CutePDF printer that contains your 
computer name.

5. Click Ok and CutePDF should pop up a window on your computer allowing you to save a PDF 
to your computer. You can then print the PDF to your local printer. Both charts should be 
contained within the pdf.
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Important: You must have the word company somewhere in the account name for all company value 
entries. If you used a different word, change it in cell O2. Make sure you used the same word for 
every company value entry. Only one company value should be entered per pay period.

FRM Numbers History (FRM_2 tab)
This chart reports provides further details and is rarely given to the client.

1. Go to the orange section toward the top of the Data Entry form and select the Client and 
enter the date of the upcoming meeting.

2. Click tab labeled FRM_2 at the bottom of the spreadsheet.

3. Click the Update Report button.

4. Using the Excel Menu, click File → Print. Choose the CutePDF printer that contains your 
computer name.

5. Click Ok and CutePDF should pop up a window on your computer allowing you to save a PDF 
to your computer. You can then print the PDF to your local printer. Both charts should be 
contained within the pdf.
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